Welcome to Koi Forum. Is this your first visit? Register
Results 1 to 8 of 8

Thread: Help help help

  1. #1

    Help help help

    Hi all, hope everyone is well? Anyhow got a problem, my set up is 16000lts Pond with Bead filter/ultrasieve and bakki shower. My sieve isn't working as it should! I seem to have water backing up in the sieve float side! when I purge the sieve the weir doesn't come back up! especially if I turn off the skimmer and just have the bottom drain returning the water. Any ideas? Thanks. Paul

    P.S. Tomorrow I'm going to take the float out and see if there is a problem with that, but I cannot get my head round this snag!



  2. #2
    Senior Member Rank = Grand Champion davethefish1's Avatar
    Join Date
    Apr 2019
    Location
    Bedworth
    Posts
    3,914
    Thanks / Likes
    8508
    what brand sieve is it?
    if it's a cetus sieve there is a concertina rubber boot connecting the weir i think, and they are known to split over time.
    simple job to replace iirc...

  3. #3
    Ultrsieve 3 Dave

  4. Thanks davethefish1 Thanked / Liked this Post
  5. #4
    Senior Member Rank = Grand Champion davethefish1's Avatar
    Join Date
    Apr 2019
    Location
    Bedworth
    Posts
    3,914
    Thanks / Likes
    8508
    Quote Originally Posted by PTMiller View Post
    Ultrsieve 3 Dave
    i've never had a sieve, and am not familiar with the ultra sieve's .
    but maybe some else here, has had an ultra sieve III....?

  6. #5
    Hopefully, I'm a bit worried the bottom drain might have a blockage! Fingers crossed it's just the float. Thanks

  7. #6
    Senior Member Rank = Grand Champion davethefish1's Avatar
    Join Date
    Apr 2019
    Location
    Bedworth
    Posts
    3,914
    Thanks / Likes
    8508
    if you push the weir down,
    and it doesn't flood the sieve with a faster flow of water, and/or the level in the weir drops, not able to keep up.
    that sounds like it might be a restriction in the pipe line...

    anything like this?




    perspex ultra sieve to see the workings

    Last edited by davethefish1; 31-01-2022 at 10:55 PM.

  8. #7
    Senior Member Rank = Jussai Twhitenosugar's Avatar
    Join Date
    Apr 2020
    Location
    Europe
    Posts
    1,435
    Thanks / Likes
    2266
    I have a midi sieve. So not exactly the same sieve.

    But I find the floating Weir plate can stick, which means as the sieve mesh gets flooded, the floating Weir does not rise.

    If that's the issue you have, then a bit of grit may have got in the side channels that the Weir slides up and down in.

    When mine does that (I got it second hand and it seems pretty old) I manually pull the floating Weir up until the water on the mesh drops below it and the water level on the inlet rises. I then let go and the Weir tends to stay put at the right height then.

    Maybe give that a go, it might just sort it?

    If not then has the float filled up with water and lost its boyancy?

    Sent from my Pixel 4a (5G) using Tapatalk
    13,000L fibreglassed raised pond with window

  9. #8
    No mine fills up fully on the float side of the sieve, plus I've noticed when i clean the filter the waste is backing up through the overflow pipe back into my pond!!
    Cheers
    Paul

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 08:37 AM. Online Koi Mag Forum
Powered by vBulletin® Version 4.2.3
Copyright © 2022 vBulletin Solutions, Inc. All rights reserved.

vBulletin Improved By vBFoster® (Lite Version), © UltimateScheme, Ltd.