Welcome to Koi Forum. Is this your first visit? Register
Results 1 to 2 of 2
  1. #1

    Profi heater help

    Hi all , I recently bought the above heater , after unboxing i realised the installation guide was very vague and also had a 2 pin plug ,so I connected it up to the pipework and phoned up the dealer I bought it from to ask about the plug he said buy a european plug adaptor ,done that , with thermostat set at 10 switched on expecting the green light to come on and nothing is happening, anybody with any ideas ps the box has made in Virginia USA written on it ,would that make it a USA plug adaptor as opposed to European..



  2. #2
    Extreme Koi Member Rank = Supreme Champion Andy1671's Avatar
    Join Date
    Sep 2014
    Location
    Dartford
    Posts
    5,734
    Thanks / Likes
    2467
    Try turning the dial up a bit to see it the heater clicks on.
    It maybe that your water is warmer than the 10 degrees youve set it at.
    5000 Gallon Fibreglassed Pond With 54" x 27" Infinity Window
    BD300 Drum Filter
    Artesian 0.5hp - Aquadyne 4.4c Beadfilter - PS4 Protein Shower
    Badu Eco Touch - EP20 UV Sterilizer - ASHP - Venturi
    Hi Blo 60 - Medo 45 - Spindrifter Bottom Drain
    Wide Mouthed Skimmer

  3. Thanks anne, freddyboy Thanked / Liked this Post
 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 09:16 PM. Online Koi Mag Forum
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.

vBulletin Improved By vBFoster® (Lite Version), © UltimateScheme, Ltd.